SVX日記

2004|04|05|06|07|08|09|10|11|12|
2005|01|02|03|04|05|06|07|08|09|10|11|12|
2006|01|02|03|04|05|06|07|08|09|10|11|12|
2007|01|02|03|04|05|06|07|08|09|10|11|12|
2008|01|02|03|04|05|06|07|08|09|10|11|12|
2009|01|02|03|04|05|06|07|08|09|10|11|12|
2010|01|02|03|04|05|06|07|08|09|10|11|12|
2011|01|02|03|04|05|06|07|08|09|10|11|12|
2012|01|02|03|04|05|06|07|08|09|10|11|12|
2013|01|02|03|04|05|06|07|08|09|10|11|12|
2014|01|02|03|04|05|06|07|08|09|10|11|12|
2015|01|02|03|04|05|06|07|08|09|10|11|12|
2016|01|02|03|04|05|06|07|08|09|10|11|12|
2017|01|02|03|04|05|06|07|08|09|10|11|12|
2018|01|02|03|04|05|

2007-01-12(Fri) アチラが立てば、サーバが立たず

  さて、仕事が忙しいながらも、休日までは侵食されなかったので、元気いっぱいにサーバイジリである。

  このNASは、VIAのEpiaML800MHz版に、ATA133で160Gの3.5inchHDD、ギガビットの蟹NICを組み合わせ、小型の筐体にパッケージングした製品である。初期状態ではBSDベースのOSが導入されており、基本的にはNASとして利用するためのものだが、当然ながら最初から素直に利用するつもりは毛頭ないオイラである。

  画像の説明

  まずはイキナリだがケースを外す。で、裏面に現れた各種「非サポート」コネクタに、PS/2キーボード、マウス、液晶ディスプレイをつないでしまう。で、電源オン。これまたイキナリBIOS設定に移動し、念のため初期状態の設定をデジカメでバシバシと保存しながら、オンボードNICを有効にするのであった。そうなのだ。この製品はギガビット対応NASに仕上げるため、ひとつしかないPCIスロットにロープロファイルなギガビットの蟹NICが刺さっており、マザー上の100Mビットは初期状態では殺されているのである。つまり、それを生かせばマルチホームになり、ルータとして稼動可能なのである。

  で、早速だがRHEL4のインストールである。しかし、手元にはCDROMドライブがない。どうするか。ここはUSBブートを使って、玄箱をNFSインストールサーバに、インストール作業を進めるのである。手元のUSBメモリにRHEL4のインストールCDの/images/diskboot.imgを「dd if=/images/diskboot.img of=/dev/sdb」てな感じで書き込む。でもって、NASのBIOSの起動設定を「First boot: [USB-HDD]」にして……起動しない。なんで?

  うーん、なんだか、メモリチェックが始まらなくて強制リセットをかけたり……なんだか動作自体が安定しないなぁ……と感じつつ「First boot: [USB-FDD]」にしてみるがやっぱり起動しない。まさか、NAS用のハードだからBIOSが特別な内容になっているとか? 「Boot Other Device: [Enable]」とかにしてもダメだし……んなアホな……と思いながら「USB ブート」とかでググると、Epiaは「First boot: [USB-ZIP]」で起動するという情報が……おっと、起動したッ!! なんでZIPでッ!? まぁ、いっか、起動すりゃ。

  「boot: linux rescue」でレスキューモードに移行する。起動ディスクの内容はNFSの先にあるので、玄箱のisoのあるディレクトリを指定する必要があるが、無事、レスキューモードでの起動に成功した。USB接続のHDDをつないで、現状のディスクの内容を書き出す。/dev/hda1と/dev/hda2をまるごと、それと/dev/hda3の先頭1MB。まぁ、初期状態のOSを使うことはないと思うが、念のためだ。

  再起動。もう一度USBメモリからブートするが、今度は「boot: linux askmethod」として、通常のGUIインストールプロセスを起動する。パーティションは4Gをふたつ。あろうことか、そのふたつでRAID1、ミラーリングアレイを構成してしまう。でもって……あ、ホスト名を決めなきゃ……どうしよう……

  ……Linuxサーバからしてみれば、オイラがフリーズしたのかと思っただろう。それくらいホスト名に悩みまくる。WRAPはwrap、玄箱HGはkuroと安直に決めたが、この製品はLHD-NAS160V、愛称NetPocket……非常にホスト名に向かない名前なのだ。筐体が黒いから黒に関連する言葉がいいけど……軽く1時間は悩んだ挙句「chrome」に決定した。元素のクロム。イメージは、強固な金属、オレンジの溶液、有毒、黒という色にも掛けている。スペルも短くて覚えやすい。気に入った。

  さて、名前に悩んだのはウソのように、適当にパッケージを選んでインストール完了。イザ、起動ッ!! ……しない。なんで? 「Missing operating system」ってディスク読んでるそぶりもないじゃんよ。またもや、BIOSのBOOT設定をどのように変えようが、ブートする気配がない。

  まぁ、動かない理由はいくらでも思い当たる。やっぱり元がNAS用のハードだからBIOSが特別だとか? HDDがつながっているのがマスタでない? マザーにヘンなジャンパが当たってるとか? USBブートからのネットワークインストールが悪さしている? 1ドライブでソフトRAIDなどという妙な設定にしているから? ……とりあえず、ハード面でももっとバラして目視確認したほうがいいな……というところで、午前4時。

  画像の説明

  もしかしたら、RHEL4のインストールはできないんじゃないかなどという不安を抱えつつ寝床に行く。非常にもやもやするが仕方ない……今日はここまで。おやすみ。